Query Delays
Incident Report for Indicative
Resolved
This incident has been resolved.
Posted Dec 06, 2022 - 19:02 UTC
Investigating
We're monitoring some intermittent delays due to heavy traffic. Users may see occasional errors when running queries.
Posted Dec 06, 2022 - 16:33 UTC
This incident affected: Web Application (app.indicative.com).